Microsoft, Update… And Loss of Internet Access

Because hardware problems, I stayed 2 days without computer.

Then, I discovered there is a life beside computers 🙂

But it is not the point of my post.

After my computer was repaired, and after all the usual stuff (put back your normal settings and so on), I was checking my emails during an automatic Microsoft update.

And then… No more Internet. No more connection…

I reset my modem. No results.

I reset my router. No results.

I check my IP, Hosts, DNS… Everything is fine. So the problem seems to come from my side, not the connection by itself (confirmed also by ipconfig, ping…).

After more than 3 hours of testing, thinking, and… fighting against the will to format my hard disk, I started to think that maybe my security programs could be the cause.

No reason, but anyway, I was short of new ideas.

After a while, I was testing my two firewalls (yes, I know, it is better to have only one. So what? 🙂 ). One of them is a freeware: ZoneAlarm.

I closed it and started the usual tests.

Do you know what? Everything was fine after…

So I looked at the last Microsoft automatic update. It included Microsoft Update KB951748.

I checked some forums, and yes, the update could cause loss in Internet connection!

The Website of Zone Alarm confirmed it too HERE.

In fact, the problem seems to only concern the users of ZA (all versions).

Solution offered by ZA:

Option 1: Move Internet Zone slider to Medium

  1. Navigate to the “ZoneAlarm Firewall” panel
  2. Click on the “Firewall” tab
  3. Move the “Internet Zone” slider to medium

Option 2: Uninstall the hotfix

  1. Click the “Start Menu”
  2. Click “Control Panel”, or click “Settings” then “Control Panel”
  3. Click on “Add or Remove Programs”
  4. On the top of the add/remove programs dialog box, you should see a checkbox that says “show updates”. Select this checkbox
  5. Scroll down until you see “Security update for Windows (KB951748)”
  6. Click “Remove” to uninstall the hotfix

In another words… there are no other ways…

So be aware!

Advertisements

4 Responses

  1. This has happened to me also but i don’t use Zone Alarm. HELP!!

  2. You just posted a comment and you have no access to Internet?
    🙂

  3. I’m having weird glitches with my internet since the updates this weekend (found you while searching for an answer). I use a Sprint broadband datacard. Some sites show up (missing a variety of images and contain broken links – yours included), some sites do not show up at all even though I KNOW I’m connected, I send/receive email through Outlook almost all the time but occasionally it glitches too for certain email accounts. Sprint verified my card is working properly, I am connected, but regardless of which browser I use, certain things are just not working correctly. Haven’t found anyone with these same glitches yet – but I’m searching. Thanks for your post. Wish my problem was with ZoneAlarm, at least then I’d know what was going on. 🙂

  4. […] – bookmarked by 5 members originally found by jycr753 on 2008-08-16 Microsoft, Update… And Loss of Internet Access https://fvarga.wordpress.com/2008/07/11/microsoft-update-and-loss-of-internet-access/ – bookmarked […]

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: